Connectivity Issue with EE - United Kingdom (GBRME)

Incident Report for Velos IoT Service Update

Resolved

The incident has now been resolved.

Traffic has returned to expected levels, and no further impact is currently being observed.

If you experience any further issues, please email support@velosiot.com.
Posted Jun 18, 2026 - 18:04 UTC

Monitoring

We are now seeing signs of recovery.

Traffic levels are returning, and our remote testing is showing successful results. We will continue to monitor the network closely over the next few hours to confirm full stability.
Posted Jun 18, 2026 - 15:31 UTC

Investigating

We’re currently investigating an issue affecting connectivity on EE in the United Kingdom. Devices attempting to roam on EE may be unable to register or could experience unstable data and SMS services.

At this stage, the issue appears isolated to EE only. Other networks in the United Kingdom are operating normally and should be used where available.

Our network partners are investigating, and we will provide a further update as soon as more information is available.
Posted Jun 18, 2026 - 13:51 UTC
This incident affected: Roaming Partners.