Connectivity Issue / ICCID Range 893720*

Incident Report for Velos IoT Service Update

Resolved

This issue is now resolved.
If you experience any further issues, please contact us at support@velosiot.com.
Posted Feb 20, 2026 - 21:00 UTC

Monitoring

We are starting to see successful 2G and 3G registrations and services are now beginning to recover. We will continue to closely monitor performance over the next hour to ensure full stability.
Posted Feb 20, 2026 - 19:50 UTC

Investigating

Affected ICCID prefix: 893720*

We are currently investigating an issue affecting 2G and 3G services, which may impact new device registrations and initial network attachment. SMS services on these technologies may also be intermittently impacted.

Existing 2G and 3G device connections remain stable and operational. 4G services are not affected.

We are actively working with our network partner to identify the root cause and restore normal service.

Next update: 20:30 UTC
Posted Feb 20, 2026 - 17:58 UTC
This incident affected: Core Network (Global IoT Data Connectivity, SMS Origination, SMS Termination).