Connectivity Issue with MTN - South Africa (ZAFMN)

Incident Report for Velos IoT Service Update

Resolved

MTN traffic has stabilised and remote testing is showing successful connectivity. Traffic levels have returned to expected ranges and services are operating normally.

If you experience any further issues, please email support@velosiot.com.
Posted Feb 18, 2026 - 18:43 UTC

Update

MTN traffic has stabilised and we are seeing improvements, remote testing is now providing successful connectivity results. However, services on MTN remain below pre-incident levels. We will continue to monitor and further updates will be provided.
Posted Feb 18, 2026 - 14:59 UTC

Investigating

We’re currently investigating an issue affecting connectivity on MTN in South Africa. Devices attempting to roam on MTN may be unable to register or could experience unstable data and SMS service.

At this stage, the issue appears isolated to MTN only. Other networks in South Africa are operating normally and should be used where available.

Our network partners are investigating, and we will provide a further update as soon as more information is available.
Posted Feb 18, 2026 - 11:07 UTC
This incident affected: Roaming Partners.